COMMUNITY

Http Error #403 for release files

I tried to run haxelib set openl 8.9.1 but I got error Http Error #403 as below:

haxelib set openl 8.9.1                                                                                                                 10557  17:16:09
Library openl version 8.9.1 is not installed
Would you like to install it? [y/n/a] ? y
Downloading openl-8,9,1.zip...
Download complete: 0.24KB in 0.6s (0.3KB/s)
Failed to download https://lib.haxe.org:443/files/3.0/openl-8,9,1.zip. (1/3)
Http Error #403
Download complete: 0.24KB in 0.5s (0.4KB/s)
Failed to download https://lib.haxe.org:443/files/3.0/openl-8,9,1.zip. (2/3)
Http Error #403
Download complete: 0.24KB in 0.5s (0.4KB/s)
Failed to download https://lib.haxe.org:443/files/3.0/openl-8,9,1.zip. (3/3)
Http Error #403
Error: [file_open,/usr/local/lib/haxe/lib/openl-8,9,1.zip]

Called from /Users/vsts/agent/2.155.1/work/1/s/std/neko/_std/sys/io/File.hx line 49
Called from haxelib/client/Main.hx line 986
Called from haxelib/client/Main.hx line 978
Called from haxelib/client/Main.hx line 1410
Called from haxelib/client/Main.hx line 1401
Called from haxelib/client/Main.hx line 493

Works for me.
Could you try from the other network?

Now I get 403 too.

@andyli restarted the server. Try now.

haxelib set openfl 8.9.1 You have a typo! You want to do openfl :stuck_out_tongue:

1 Like

Yeah, it sure looks like it downloaded “about 246 bytes of something-or-other” before settling down to the task of downloading a package that isn’t there because the name was mispeled.

1 Like

Can you please type the correct way of setting library version?

He did, you forgot the f of openfl, you can paste his command.

I get a similar error when updating all packages. Hit the error with Console.hx. Filed a bug report:

Oh! Thanks guys, I really don’t know how I missed that :sweat_smile: