COMMUNITY

Unsupported dune version when building Haxe from source

I believe that this is NOT an error specific to Haxe - I’m just hoping that the Haxe community can help point me in the right direction for solving as I’m not sure what I’m missing. I’ve Googled and found similar issues but no proposed solutions have worked for me. My issue is that after I recursively download the Haxe source and run:

make

I receive the following error:

File "dune-project", line 1, characters 11-15:
Error: Version 1.11 of dune is not supported.
Supported versions:
- 0.0
- 1.0
Makefile:71: recipe for target 'haxe' failed
make: *** [haxe] Error 1

I’ve downgraded dune to 1.0 by running:

opam install "dune=1.0.0"

but no matter what version of dune I install I always receive the same error stating that version 1.11 is not supported. It’s almost like it’s looking somewhere else for dune.

I’ve tried these two proposed solutions:

  1. https://stackoverflow.com/questions/59639029/error-version-1-11-of-dune-is-not-supported
  2. https://stackoverflow.com/questions/57594205/dune-version-not-supported/57661144#57661144

Opam says it is at the newest version and when I check which dune - I only have the 1 installed in my home ~ directory.

Let me know if you need any more information.
Thank You!

I have dune 1.11.4 installed, and it works fine.
What are you opam and ocaml versions?

Thanks for the response :slight_smile:

opam: 1.2.2
ocaml: 4.02.3

  • Forgive my ignorance but I’m trying to install dune 1.11.4 like you have by running:

opam install "dune=1.11.4"

but I get this error:

[ERROR] No package matches dune.1.11.4.

It looks like there are newer versions of Opam and Ocaml - I will try upgrading them first to see what happens.

Afair opam 2 is required.

Thank you! I had to update opam and then work through installing quite a few missing dependencies, but once all dependencies were installed everything worked. I’ll close this ticket :slight_smile: