Trying to publish to haxelib using CI/CD

I already have an almost working flow for building and publishing haxe libraries.
However, for some reason that I can’t understand, I a getting a error at the end of haxelib submit. The file gets accepted, it gets uploaded, but at the end, suddenly, it throws an error.

This is the github flow: haxe-nvim/publish.yml at master · danielo515/haxe-nvim · GitHub

And here is the log of the haxelib step:

Thanks for any help.

I’m running into what appears to be the same issue. However, I’m not submitting to Haxelib on Github Actions or any other CI server. I’m running haxelib submit in a terminal on my local computer (macOS Ventura 13.2.1, M1).

Sending data.... 
File #94248774 accepted : 122365071 bytes written
Processing file.... 
Error: Failed with error: Eof

I was able to successfully submit a different library earlier today.

Just wondering out loud… I wonder if it has something to do with the size of the submitted files. Maybe the Haxelib server is having trouble with larger files over 10MB or something like that.

I share the same local setup as you do, but in my local environment it submits just fine.
My CI is building in Ubuntu, so it is not exactly the same environment. Maybe there the file gets larger? Or somehow something cuts the connection because it is slow?

See Error: Failed with error: Eof during processing file · Issue #589 · HaxeFoundation/haxelib · GitHub

I am now able to submit successfully after the fix to the Haxelib backend.

So all I need to do is retry?

Yeah, give it a shot. I initially got an HTTP 502 error, but I tried a second time, and it worked.

I can confirm that it works wonderfully in CI.