COMMUNITY

Project will not load due to Java Heap Size error

I have a fairly large project that will no longer run. I am targeting HTML5 -final in “realease” mode. It’s a HaXe +OpenFL project.

Any ideas how to fix this?

Try to set Xms and Xmx options , at example :
-Xms64M -Xmx1024M

That stacktrace looks like it comes from the Google Closure compiler which is used for JS minification in the release mode for HTML5.

I’ve tried that, but am unsure if I did it correctly. I went to Windows search and called up a command prompt, then typed c: java -Xmx1024m and here’s what it showed:

Try:

set _JAVA_OPTIONS=-Xms64M -Xmx1024M

Then run whatever is starting up the VM in the same command prompt… Or add that env variable globally so all processes will start with those params

I’m afraid this is a little beyond what I understand. I do appreciate your reply and attempt at helping.

Then

And then try to do whatever you were trying to do again… if you already have a command prompt open you may need to close it and start a new one for the environment variable to take effect

Hope that helps :slight_smile:

2 Likes

Now we’re getting somewhere. Thank you for putting in the time to make visuals. That was very helpful. I’ve almost got it. Here are the 2 errors Haxedevelop throws upon the adjustments:
heapErrors

You set the option too high, isn’t -Xmx1024M enough?

1 Like

Nope, but let me try that again and do a complete reload of the system.

Wow… ok, perhaps I failed to reset the system, because that worked. Thank you, both of you! Several hundred users were depending on this update.

1 Like