COMMUNITY

No autocompletion in VsCode

vscode

(Grégoire Calonne) #1

Hello

I have a problem i did install haxe without touching any setting during installation
And i don’t have auto completion in VsCode i just see a “building cache” that been doing during 2 hours :confused:

Here is what i get from output console

Error: Invalid directory: c:/Users/Grégoire/Desktop/Ludus

SyntaxError: Unexpected end of JSON input

What can i do ?

Best regards


(Misiur) #2

Which haxe version do you use?

Also could you try setting up your project in a folder which does not have non-ascii chars (not in the Grégoire folder)? That would help to narrow the issue scope.


(Grégoire Calonne) #3

I’m on haxe 3.4.7

Here is what i got when setup a project on a folder that does not contain non-ascii chars


Haxe language server started

Listening on port 6000

Haxe version does not support JSON-RPC, using legacy --display API.

Building Cache…