COMMUNITY

Linc+Kha make issue [Closed]

I have need to use linc_openal in a kha project. I get past the haxe/khamake portion fine with no errors. The make portion is returning an error that my library cpp file can not find ‘linc_openal.h’. I have a build.hxml for the library and have included the linc_openal in the khafile.js.

I’ve tried using the @:include in my library .hx file but that didn’t take care of the issue.

Here’s what I got:

KORE_A3 -c …/Sources/src/sndm/Sndm.cpp -o sndm.o
…/Sources/src/sndm/Sndm.cpp:6:10: fatal error: linc_openal.h: No such file or directory
6 | #include “linc_openal.h”
| ^~~~~~~~~~~~~~~

package sndm;

import openal.AL;
@:include(‘linc_openal/linc/linc_openal.h’)

-cp src
-L linc_openal
-D linux
-cpp bin/

project.addLibrary(“sndm”);
project.addLibrary(“linc_openal”);
project.addDefine(“linc_openal”);

Have you tried setting up a Kinc project with the includes and adding this to the kha project? I think you need to for native stuff.

It appears the Conrad uses a make system that won’t allow using a “wrapper” library. You need to make a “wrapper” that Kinc likes.

I don’t know what a wrapper library is but Kha doesn’t use hxcpp’s build system at all so any linc things can not work straight away. But that’s fine. What’s not fine is calling me Conrad, I will talk to my lawyer about that.