COMMUNITY

IntelliJ Haxe Plugin

Hi all,

starting to migrate from flash to haxe on my Mac, I finally got “Hello World” stuff running with IntelliJ and the haxe plugin. Last annoying thing remaining is missing Code-Completion. IntelliJ just ignores every openfl Namespace.
Any hints to handle this?

Regards
Andi

If IDEA doesn’t have the OpenFL library specified in your IDEA project, then it won’t be able to provide completion. IDEA doesn’t (yet) read Haxe project files to determine the included libraries. For now, you must add haxelibs manually in the File->Project Structure... dialog. You can add them at the project or the module level. When adding, traverse to your haxelib directory and select the directory at the version level (for example, select the directory 5,1,5 from the following path …/haxelib/openfl/5,1,5/). Tell IDEA that the directory contains both Library Classes and Library Sources.

You can augment IDEA’s completion by asking the compiler for help: Turn it on via the “Completion: Use Compiler” checkbox in the Haxe SDK configuration panel ( 'File->Project Structure…->SDKs{left panel}->{Your Haxe SDK, middle panel}`). If you don’t see the check box, then select another SDK and select the Haxe SDK again (there is a known bug in the layout).

Hope this helps,
-Eric