HXCPP Won't debug in VSCode

Hey! So I have seen other people had this issue a while back but nothing they did worked for me.

I am trying to run the HaxeRepro project on MacOS Ventura with VSCode 1.84.0.

I am running the C++ launch config and I have hxcpp-debugger installed and all the extensions for VSCode, but I can’t get the debug server to launch.

Everything else works. The Main-debug executable is created and runs, but in VSCode the trace(“Test”) does not output to the console and the breakpoint doesn’t get hit.

Anybody else having this issue?


To anyone who reads this, I want you to know I am a moron. The file that gets generated on a mac doesn’t have a .exe extension but the launch.json is looking for it… so you just remove the .exe part in the launch.json and it works perfectly. On the plus side the weekend is now looking fun!

Another thing to know is the “-debug” suffix in the executable name is only there in debug mode, so if you build in release mode it’ll only be named Main.
I ended up debugging the wrong exe several times because of that.

If you add to your hxml:

--define HAXE_OUTPUT_FILE=myapp

the executable will be named myapp both in release and debug mode, which can be useful.

Thank you, that is actually really useful to know.

Not sure you would have the answer to anothe question, but I can’t get VSCode to recognise SDL. It all compiles, launches, and debugs but vscode shows a bunch of red squiglies and there is no intellisense.

Not sure if it is possible to get the haxe extension to know about the linc_sdl.

If you have the correct hxml used you should have code completion.

Do you add any arguments to it in a task instead of having it in the hxml?
That would make it work only when compiling but not in the ide.

Or maybe you have multiple hxml? If so be sure to check which one is used, you can check in the status bar.

Yeah that worked! Just added to build.hxml:

-lib linc_sdl

-D mac

Now I have code completion and it compiles and runs.

Thank you so much.