COMMUNITY

How to compile hashlink to native app

haxe-hl

#1

Hello
Please help
I’m trying to compile the very simple Heaps example into a self executable app, getting a bunch of errors then fails

In file included from output.c:396:0:
./hl/types.c:16959:2: error: too few arguments to function ‘hl_init_enum’
  hl_init_enum(&type$3698);
  ^
In file included from /usr/local/include/hlc.h:26:0,
                 from ./hl/code.h:6,
                 from output.c:2:
/usr/local/include/hl.h:389:13: note: declared here
 HL_API void hl_init_enum( hl_type *et, hl_module_context *m );

I’m following the instructions here https://hashlink.haxe.org/
I’m working on linux

thank you


(Valentin Lemière) #2

What are your hl and haxe version?

You might have a haxe version too low.


#3

I was using haxe 3.4.7 and hl 1.5


#4

Most likely hashlink 1.5 requires Haxe 4.0 preview 3+


#5

Switched to 4.0 preview 3 and Hashlink 1.5, still not working

here’s the output, or part of it
https://pastebin.com/MNcKBRpX

thank you


#6

Just tried with a simple hello world app and same result, was trying to discard that Heaps was the issue and is not


#7

also if I try to run the .hl directly I get another error

hl output.hl
src/module.c(296) : FATAL ERROR : Invalid signature for function sdl@gl_options : Piiiii_v required but Piiiiii_v found in hdll