Haxe Toolkit broken by nightly build


Before posting an issue on Haxe repo, I would like to check here for a solution.

I was using haxe 4.preview4, and all was good in the world. Then I decided to switch to the latest nightly build, and things broke.
First symptom was vscode Haxe Extension telling me it failed to parse Haxe version. The version string was not displayed in the error message, so I went in Terminal (I am using windows, please don’t throw things at me) and typed ‘haxe --version’. It failed to launch haxe with an error window.

It’s in french, but it says “App failed to launch (0x…). Click ok to close the app”.

Weird. I tried various combinations. Haxe is broken, any haxe command fails. Testing further, haxelib is working, but haxeliblist returns nothing. Either it goes to line and terminates in the terminal, or lead to an empty file when redirecting output. Haxelib version returns 3.3.0

When reinstalling v4.preview4, haxe is fixed and works ok. As soon as I install a nightly, it breaks.

I tried nightly builds with following IDs :

  • 28ab3ce
  • 3da30c3

Any help appreciated :slight_smile:

Thanks Dimous, didn’t notice that issue :slight_smile:

For future reference : workaround si to install x86 version instead.