Haxe diagnostic errors persist after fixing them and saving the file (VSCode)

Hi everyone, I’m new to Haxe and I just installed the language version 4.2.5, the Heaps game library, and the Haxe Extension pack for vscode.

The code diagnostics work as expected for detecting errors, but they don’t go away after fixing and saving. For example, if I remove a semicolon and save, the error comes up saying missing semicolon. But if I add the semicolon back in and save, the diagnostic error remains, and this occurs with other kinds of errors too. I have to restart vscode or use the “Reload Window” command to make the error go away.

Has anyone encountered this before? I figure it’s got something to do with my vscode settings. I’ve tried disabling Prettier and every other extension but the Haxe extension pack ones. Thanks.

Do the errors remain if you rebuild the project? This is done by running Ctrl-Shift-B

1 Like

Using that rebuild command shows me a message about “No build task to run”. I may be missing some setup? I’ve been building & running using the command “haxe --main HelloWorld --interp”, and the errors do remain after building with that command

If you make a build.hxml file in your project that contains the following:

--main HelloWorld

You can run the project via vscode using the keyboard shortcut (or externally by haxe build.hxml). If you run it through vscode it might get rid of the error message perhaps?

1 Like

That turns the filename from red to white but the error highlighting in the code is still there unfortunately.

I’ve tried reinstalling VSCode as well as the extensions and that hasn’t worked either.

Ok, another reinstall after completely nuking my VSCode installation and deleting all vscode related cached data in my user folder has fixed it! There must have been some weird setting conflicting with the diagnostic tool. Thanks for the help.

If anyone else ever runs into this, here’s the folders I deleted after uninstalling vscode: