[solved] msvcr120.dll missing when building HashLink to .exe via redisthelper (Windows10)

I’m using redistHelper to build HashLink files to .exe-files on my Windows 10.

Recently I had problems because redistHelper wasn’t able to find a file called msvcr120.dll and thus couldn’t build my project.

  1. But I had the community version of Microsoft Visual Studio (from 2019) still installed and found a similar file there under:
    C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\msvcr120_clr0400.dll

  2. I copied the file to ...\HaxeToolkit\haxe\lib\redistHelper\git\redistFiles\hl64\msvcr120.dll.
    This works because this is one of the paths where redistHelper searches for files.
    (Note that I’m using the git version of redistHelper here and as you can see I’m on a x64 machine: hl64.)

  3. This means I also renamed the file from msvcr120_clr0400.dll to msvcr120.dll.

Tested so far:

  • This solution worked at least for a very basic console network-socket app and even a Heaps project (that uses the libraries heaps and hlsdl but no game assets)

Maybe this can help someone, at least even myself when I forget this later…

Wait! The file is already there?

(!!!) edit: Actually it seems it even works with the dll file that is already there in the hl32 folder of redistHelper. You just have to copy it to the hl64 folder of redistHelper’s redistFiles. (In doubt also consider rebuilding redistHelper itself by its hxml-file.)